Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2985 - Red Hat 6.0 sparc (SS5) CG6 X server crashes
Summary: Red Hat 6.0 sparc (SS5) CG6 X server crashes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 6.0
Hardware: sparc
OS: Linux
high
high
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-23 16:42 UTC by Marco Colombo
Modified: 2008-05-01 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-31 20:51:26 UTC


Attachments (Terms of Use)

Description Marco Colombo 1999-05-23 16:42:22 UTC
The X server crashes quite often: it seems crashes are
much more frequent where the server is asked to render
some fonts (killer apps are: Netscape, The Gimp, even
xfontsel). The bug shows up also letting the Xserver access
the fonts directly (disabling xfs). I was NOT able to
reproduce the bug 100% of the times, but just a few
minutes of "random" web browsing or rendering some text in
some Type1 fonts with the gimp or xfontsel should be
enough to trigger it. An X session with just xterms runs
for hours without crashes. I've tried the enlightenment WM,
icewm, even a plain-old tvtwm (no panel, no backgrounds,
...) with same results. I've tried opening Netscape from
other hosts (4.51 for Linux/i386, 4.51 for Solaris) with
same results.

Comment 1 Jay Turner 1999-05-24 18:45:59 UTC
We are aware of this problem and are working on a fix for it.  Thanks
for the information.

Comment 2 Matt Wilson 1999-05-27 21:32:59 UTC
*** This bug has been marked as a duplicate of 2818 ***

Comment 3 Marco Colombo 1999-06-01 11:10:59 UTC
Still happens. While it seems to be a little less frequent, it's still
there. Just fire The Gimp, and force it to display some text in
some of the available fonts. Sooner or later it will crash the X
server.
Of course, kernel RPM is kernel-2.2.5-21. The system is a Netra i
(SparcStation 5). I think the FB is a TurboGX, anyway dmesg says:
fb0: cgsix at 0.50000000 TEC Rev 4 CPU sparc Rev b
and it's a 8 bits (256 colors) depth.
There are no messages on X server stderr or syslog. Not all X clients
die, actually I have to kill xterms by hand.
The system itself never crashed.
BTW, the old system was RHL5.1, and worked just fine (for months).
Hope this helps.

Comment 4 David Miller 1999-06-02 09:52:59 UTC
Can you verify that /etc/silo.conf is in fact setup properly
so that it will be booting the new kernel?  Just want to verify
this.


------- Email Received From  Marco Colombo <marco@esi.it> 06/02/99 06:08 -------

Comment 5 Preston Brown 1999-06-02 14:14:59 UTC
Pasted from attached email:

[root@NOC marco]# uname -a
Linux NOC.ESI 2.2.5-21 #1 Sun May 23 15:25:41 EDT 1999 sparc unknown
[root@NOC marco]# cat /proc/version
Linux version 2.2.5-21 (root@bart.devel.redhat.com) (gcc version
egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)) #1 Sun May 23
15:25:41 EDT 1999

Comment 6 Preston Brown 1999-08-31 20:51:59 UTC
running XFree86 3.3.5 (which is about to be released as errata) and
kernel 2.2.5-22, available from the updates site, I was able to
extensively render type1 fonts in gimp without crashing on the same
graphics card you have and a Sparc20.  I hope that 3.3.5 will fix your
problems.  Please get the update when it becomes available (shortly),
and if you continue to have issues, re-open the bug.


Note You need to log in before you can comment on or make changes to this bug.