Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2980 - Missing files in Perl distribution
Summary: Missing files in Perl distribution
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
: 3297 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-23 09:21 UTC by joe
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-18 16:57:43 UTC


Attachments (Terms of Use)

Description joe 1999-05-23 09:21:39 UTC
The latest versions of the official Perl distribution are
including some files which are not part of the RH Perl
distribution, mainly because the %files section of the
SPECS file is using a fixed list. This should better
be /usr/bin/* etc.

Patch follows:

*** perl.spec.orig      Wed Apr  7 05:30:23 1999
--- perl.spec   Sun May 23 11:09:24 1999
***************
*** 3,9 ****
  %define perlver 5.005
  %define perlrel 03
  Version: %{perlver}%{perlrel}
! Release: 2
  Copyright: GPL
  Group: Development/Languages
  Source0:
ftp://ftp.perl.org/pub/perl/CPAN/src/perl%{perlver}_%{perlrel}.tar.gz
--- 3,9 ----
  %define perlver 5.005
  %define perlrel 03
  Version: %{perlver}%{perlrel}
! Release: 3
  Copyright: GPL
  Group: Development/Languages
  Source0:
ftp://ftp.perl.org/pub/perl/CPAN/src/perl%{perlver}_%{perlrel}.tar.gz
***************
*** 101,128 ****

  %files
  %defattr(-,root,root)
! /usr/bin/sperl%{perlver}%{perlrel}
! /usr/bin/perl%{perlver}%{perlrel}
! /usr/bin/suidperl
! /usr/bin/perl
! /usr/bin/a2p
! /usr/bin/c2ph
! /usr/bin/pstruct
! /usr/bin/s2p
! /usr/bin/find2perl
! /usr/bin/h2xs
! /usr/bin/h2ph
! /usr/bin/pl2pm
! /usr/bin/perldoc
! /usr/bin/pod2man
! /usr/bin/pod2html
! /usr/bin/pod2latex
  /usr/lib/perl5
! /usr/man/man1/a2p.1
! /usr/man/man1/s2p.1
! /usr/man/man1/perl*.1

  %changelog
  * Tue Apr 06 1999 Cristian Gafton <gafton@redhat.com>
  - version 5.00503
  - make the default man3 install dir be release independent
--- 101,116 ----

  %files
  %defattr(-,root,root)
! /usr/bin/*
! /usr/man/man1/*
  /usr/lib/perl5
!

  %changelog
+ * Sun May 23 1999 Jochen Wiedmann <joe@ispsoft.de>
+ - Added /usr/bin/(pod2text|perlbug|perlcc|splain) to the
distribution
+ - Added lots of man pages to the distribution
+
  * Tue Apr 06 1999 Cristian Gafton <gafton@redhat.com>
  - version 5.00503
  - make the default man3 install dir be release independent

Comment 1 Jay Turner 1999-05-24 18:59:59 UTC
This matter has been assigned to a developer for further action.

Comment 2 Cristian Gafton 1999-06-18 16:57:59 UTC
Fixed in a new version of perl, available from rawhide.

Comment 3 Cristian Gafton 1999-06-18 16:58:59 UTC
*** Bug 3297 has been marked as a duplicate of this bug. ***

i have a module off of CPAN that want to use pod2text,
however the perl package that comes with RH 6.0 doesn't have
it.  my workaround was to grab the .src.rpm for perl, change
the .spec file so that /usr/bin/pod2text was included in the
file list, and then build and install.


------- Additional Comments From dkl@redhat.com  06/07/99 15:52 -------
I have verified that the perl-5.00503-2 as shipped with Red Hat 6.0
does not have the pod2text utility and also is not enabled in the perl
src rpm. But it is included with the source and as such should be
compiled also.Fixed in a new version of perl, available from rawhide.


Note You need to log in before you can comment on or make changes to this bug.