Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2978 - moving files causing issues
Summary: moving files causing issues
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: fileutils
Version: 6.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-23 04:56 UTC by cyeo
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-24 19:06:13 UTC


Attachments (Terms of Use)

Description cyeo 1999-05-23 04:56:41 UTC
When you 'force' a move to the same filename (by accident)
it will unlink the file... here is the log:

root@zeppelin:[ /tmp/test ] l
total 0
root@zeppelin:[ /tmp/test ] echo > test
root@zeppelin:[ /tmp/test ] l
total 1
   1 -rw-r--r--   1 root     root            1 May 22 22:53
test
root@zeppelin:[ /tmp/test ] /bin/mv test test
/bin/mv: `test' and `test' are the same file
root@zeppelin:[ /tmp/test ] l
total 1
   1 -rw-r--r--   1 root     root            1 May 22 22:53
test
root@zeppelin:[ /tmp/test ] /bin/mv -f test test
/bin/mv: `test' and `test' are the same file
root@zeppelin:[ /tmp/test ] l
total 0

Comment 1 Jay Turner 1999-05-24 19:06:59 UTC
This is the correct behavior for mv -f and therefore is not a bug.

------- Email Received From  "Chris Y." <cyeo@biking.org> 05/24/99 23:40 -------


Note You need to log in before you can comment on or make changes to this bug.