Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2970 - WindowMaker crashes when using Gnome pager
Summary: WindowMaker crashes when using Gnome pager
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: WindowMaker
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-22 16:46 UTC by Yaron Minsky
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-30 14:04:44 UTC


Attachments (Terms of Use)

Description Yaron Minsky 1999-05-22 16:46:41 UTC
WindowMaker version: WindowMaker-0.52.0

You can cause WindowMaker to crash by using the Gnome
pager.  In particular, start out in a situation where there
is an iconified window in another Workspace.  Then click on
the little up-arrow icon to get the list of Workspaces and
windows in those workspaces.  If you click on the iconified
window, then WindowMaker crashes.

Note that the window switching works fine if you pick
non-iconified windows.

Possibly important configuration details:
  - WindowMaker is started from "exec gnome-session"
  - I have WindowMaker icons disabled, since you get
the         same functionality from the Gnome pager's
display of
    processes.

Comment 1 David Lawrence 1999-05-24 22:33:59 UTC
I was unable to cause WindowMaker crash  as instructed using the
gnome-pager applet that ships with gnome-core-1.0.4-34 that ships with
the final release of Red Hat 6.0.

Comment 2 Yaron Minsky 1999-05-24 22:51:59 UTC
I'm pretty sure the bug is there, so let me provide some extra
information to help in reproducing:

  - You need to have the "Disable miniwindows" option set.  It's found
in the final panel of the WPrefs control panel
  - Once you set that on, you should restart wmaker

If you don't do these steps, the bug WILL NOT show up.

Hope that helps in reproducing it.  Note, I don't think this is a
gnome bug, I'm pretty sure it's a WindowMaker.  WindowMaker crashes
under some other, harder to reproduce situations.

Comment 3 Yaron Minsky 1999-05-25 05:28:59 UTC
Final note: changelog for WindowMaker
(http://www.windowmaker.org/src/ChangeLog) claims that problem is
fixed in 0.53.0.

Comment 4 Jay Turner 1999-06-30 14:04:59 UTC
Resolving bug as fixed in version 0.53.0.


Note You need to log in before you can comment on or make changes to this bug.