Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2968 - Upgrade from 5.2 will cause lots of missing files
Summary: Upgrade from 5.2 will cause lots of missing files
Keywords:
Status: CLOSED DUPLICATE of bug 2727
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 6.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-22 15:42 UTC by david.kastrup
Modified: 2015-01-07 23:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-22 17:49:29 UTC


Attachments (Terms of Use)

Description david.kastrup 1999-05-22 15:42:16 UTC
After upgrading two entirely different systems from 5.2 to
6.0, I noticed that quite a few packages would not work
properly due to missing files.  Please do an
rpm --verify -a
after attempting such an upgrade.  You will find hosts of
missing files.  I have the suspicion that there is a
correlation between packages that install .rpmorig files and
this phenomenon, but at least with the tetex-latex package,
which is missing wagonloads of files after the upgrade, no
.rpmorig file was noted in the upgrade log.

This upgrade bug seems to me to be the source for bug report
2080, too.

Affected packages can be reinstalled with
rpm -U --force

About a dozen different and unrelated packages are
affected.  Since this affects every upgrade from 5.2 to 6.0,
the severity is rather high as it causes hundreds of
thousands inconsistent RedHat 6.0 systems.  Please add
upgrades to your release testing.  As verifying an upgraded
system is a single call of rpm, this is cheap to do.

I have flagged this as an i386 error since that is the
system I use.  Thius does not mean that other architectures
might not also be affected.

Comment 1 Bill Nottingham 1999-05-22 17:49:59 UTC
*** This bug has been marked as a duplicate of 2727 ***


Note You need to log in before you can comment on or make changes to this bug.