Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 296131 - xterm does reset LD_LIBRARY_PATH
Summary: xterm does reset LD_LIBRARY_PATH
Keywords:
Status: CLOSED DUPLICATE of bug 229360
Alias: None
Product: Fedora
Classification: Fedora
Component: xterm
Version: 7
Hardware: i586
OS: Linux
low
high
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-19 12:00 UTC by Martin Gutschelhofer
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-09-19 12:11:43 UTC


Attachments (Terms of Use)

Description Martin Gutschelhofer 2007-09-19 12:00:04 UTC
Description of problem:

When starting an xterm from a shell, the LD_LIBRARY_PATH is reset and empty.

Version-Release number of selected component (if applicable):

rpm -qi xterm
Name        : xterm                        Relocations: (not relocatable)
Version     : 227                               Vendor: Fedora Project
Release     : 1.fc7                         Build Date: Fri 29 Jun 2007 12:32:57 

How reproducible:


Steps to Reproduce:
1.In a shell set LD_LIBRARY_PATH to any value
setenv LD_LIBRARY_PATH xxx

2.Launch xterm in the background
xterm &

3.In the xterm determine the value.
echo $LD_LIBRARY_PATH



Actual results:
The variable is empty



Expected results:
The variable should be set to 'xxx'


Additional info:

- I'm using /bin/tcsh as log-in shell, but I think this is irrelevant.

- When I start a 'gnome-terminal' the variable is set correctly

Comment 1 Miroslav Lichvar 2007-09-19 12:11:43 UTC

*** This bug has been marked as a duplicate of 229360 ***


Note You need to log in before you can comment on or make changes to this bug.