Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2945 - kmod problems
Summary: kmod problems
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 6.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
: 2946 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-20 22:27 UTC by abed
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-29 20:51:13 UTC


Attachments (Terms of Use)

Description abed 1999-05-20 22:27:35 UTC
I built a kernel and I answered (y) to the three
questions about module support in xconfig. Then
I recompiled the kernel and all looked ok.

Now when I reboot I get this message:

kmod: failed to exec /sbin/modprobe -s -k binfmt-464c, errno
= 8

This message scrolls down my screen forever and locks my
computer. The only way out is for me to reboot again using
the kernel that came with RH.

What is wrong ? please help me because i need to build
my own kernel....

Thanks,
Abed

Comment 1 Bill Nottingham 1999-05-21 03:52:59 UTC
*** Bug 2946 has been marked as a duplicate of this bug. ***

I built a kernel and I answered (y) to the three
questions about module support in xconfig. Then
I recompiled the kernel and all looked ok.

Now when I reboot I get this message:

kmod: failed to exec /sbin/modprobe -s -k binfmt-464c, errno
= 8

This message scrolls down my screen forever and locks my
computer. The only way out is for me to reboot again using
the kernel that came with RH.

What is wrong ? please help me because i need to build
my own kernel....

Thanks,
Abed

Comment 2 Bill Nottingham 1999-05-21 03:56:59 UTC
Look at the .config file where you compiled the kernel -
Did you say yes to 'CONFIG_BINFMT_ELF'?

------- Email Received From  "Abed M. Hammoud" <abed@anatomic.com> 05/21/99 10:42 -------


------- Email Received From  "Abed M. Hammoud" <abed@anatomic.com> 05/21/99 10:45 -------

Comment 3 Michael K. Johnson 1999-07-29 20:51:59 UTC
# CONFIG_BINFMT_ELF is not set
is your problem


Note You need to log in before you can comment on or make changes to this bug.