Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2922 - minicom no longer SGID "uucp", but /var/lock directory is group uucp
Summary: minicom no longer SGID "uucp", but /var/lock directory is group uucp
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: minicom
Version: 6.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
: 3087 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-19 05:25 UTC by pfeif
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-19 16:34:42 UTC


Attachments (Terms of Use)

Description pfeif 1999-05-19 05:25:24 UTC
In 6.0, minicom is no longer SGID "uucp", but /var/lock
directory is only group writeable and it's group is uucp,
so minicom cannot create the /var/lock/LCK..modem file so
it fails. The only workaround is to run "minicom -s" as root
to change the lock directory, but then other modem software
(such as ppp dialers) cannot know if the modem is being
used.

Comment 1 Jay Turner 1999-05-19 14:11:59 UTC
Verified that in 6.0, /var/lock is indeed not world-writable and
therefore minicom does have problems creating the lock file.

Comment 2 Jeff Johnson 1999-05-19 16:34:59 UTC
Fixed in dist-6.1 minicom-1.82-6.

Comment 3 Jay Turner 1999-05-27 14:15:59 UTC
*** Bug 3087 has been marked as a duplicate of this bug. ***

the default perms on the minicom binary do not allow it to
create lockfiles in /var/lock since /var/lock is not world
writable +t.  5.2's minicom was set gid uucp as this would
allow it to create lock files in /var/lock

bad news: normal uses cannot launch minicom


Note You need to log in before you can comment on or make changes to this bug.