Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2920 - "mount failed: Device or resource busy" during installation
Summary: "mount failed: Device or resource busy" during installation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.0
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-19 02:23 UTC by Jason Bucata
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-07 15:30:13 UTC


Attachments (Terms of Use)

Description Jason Bucata 1999-05-19 02:23:49 UTC
This bug, reported as a comment by noah@ecn.purdue.edu to
bug #2142, has occurred to me as well.

Comment 1 Anonymous 1999-05-19 03:05:59 UTC
I tried removing my /boot partition from /etc/fstab altogether,
placing boot files in the boot directory under / (where the partition
had once been mounted).  This didn't change anything; I still get the
error.  I have a *lot* of other partitions; I don't want to have to
somehow remove all of them to get this upgrade to work (if it came to
that, I'd take the opportunity to repartition anyhow, and do a
complete reinstall).

Comment 2 Jay Turner 1999-05-19 14:24:59 UTC
It is not possible to perform a hard drive installation/upgrade to the
same partition that the source files are located in, otherwise you
will receive the error that is described in this posting.

Comment 3 Anonymous 1999-06-02 04:39:59 UTC
If by "source files" you mean the RPMs, I'm upgrading from a Linux
Central CD-ROM with a boot floppy.  I'm not doing a hard drive
install.

Comment 4 Anonymous 1999-06-02 05:22:59 UTC
I looked back at the original comment, and yes, it appears that that
problem was from a hard drive install (and therefore yet another
duplicate of bug 2504, reported several times here).  This one isn't,
however.

Comment 5 Anonymous 1999-06-10 05:30:59 UTC
I tried it again, and when I got to the point where it complained, I
went over to bash, and I simply ran "umount /mnt" (where /dev/hda6 had
been mounted), and it worked fine after that.

Comment 6 Jay Turner 1999-07-07 15:30:59 UTC
*** This bug has been marked as a duplicate of 2504 ***


Note You need to log in before you can comment on or make changes to this bug.