Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2909 - in.rexecd hangs
Summary: in.rexecd hangs
Keywords:
Status: CLOSED DUPLICATE of bug 2318
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rsh
Version: 6.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-18 14:44 UTC by lionel.cons
Modified: 2015-01-07 23:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-18 16:31:24 UTC


Attachments (Terms of Use)

Description lionel.cons 1999-05-18 14:44:46 UTC
It seems that in.rexecd is buggy and hangs, it can
be reproduced on a base Red Hat 6.0 box with a simple
	rexec -l user -p pass localhost date

Doing an strace on it, we see that the rexec client sends
the port number as the first "argument":
   write(3, "1716\0", 5)                   = 5
and waits for the socket to be created
   accept(4,  <unfinished ...>
while the rexec daemon reads the second argument (user)
*before* creating the socket...

Comment 1 Jeff Johnson 1999-05-18 16:26:59 UTC
As a workaround, add -a to the rexec command line.

Comment 2 Jeff Johnson 1999-05-18 16:27:59 UTC
As a workaround, add -a to the rexec command line.

Comment 3 Jeff Johnson 1999-05-18 16:31:59 UTC
*** This bug has been marked as a duplicate of 2318 ***


Note You need to log in before you can comment on or make changes to this bug.