Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 289971 - Feature request: kingsun 959 IrDA dongle kernel module
Summary: Feature request: kingsun 959 IrDA dongle kernel module
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL: http://lwn.net/Articles/242568
Whiteboard:
Depends On:
Blocks: 427887
TreeView+ depends on / blocked
 
Reported: 2007-09-13 20:33 UTC by Paul Osmialowski
Modified: 2008-03-25 19:30 UTC (History)
1 user (show)

Fixed In Version: kernel-2.6.24.3-34.fc8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-03-25 19:30:25 UTC


Attachments (Terms of Use)

Description Paul Osmialowski 2007-09-13 20:33:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.8.0.12) Gecko/20070718 Fedora/1.5.0.12-4.fc6 Firefox/1.5.0.12

Description of problem:
I don't know if 2.6.23 is planned for both fc6 and f7, but 2.6.23 is promissed to have a module for very popular kingsun 959 IrDA dongle (newer/cheaper/worse version of kingsun dongle that is already operated by kingsun-sir module). Due to it's popularity followed by very low price I think it should be usable in user-friendly Linux distribution. Although it will be available in 2.6.23, I was able to compile and use it myself with current fc6 kernel.


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Steps to Reproduce:
1.
2.
3.

Actual Results:


Expected Results:


Additional info:

Comment 1 Jon Stanley 2008-01-08 01:52:53 UTC
(This is a mass-update to all current FC6 kernel bugs in NEW state)

Hello,

I'm reviewing this bug list as part of the kernel bug triage project, an attempt
to isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug, however this version of Fedora is no longer
maintained.

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!

Comment 2 Paul Osmialowski 2008-01-08 19:16:10 UTC
Unfortunately, ks-959 module is still not present in 2.6.23 kernel, so the bug
is still active on Fedora7/Fedora8. As the author says:
"The Linux driver was written for 2.6.22, and might get included in mainline by
2.6.24, but it should compile in older 2.6.x kernels as well."
You can download source code from here, AFAIR it compiles fine on F7, probably
the same with F8: http://palosanto.com/~a_villacis/codeprojects/ks-959.tar.bz2
Whole story is here:
http://palosanto.com/~a_villacis/codeprojects/kingsun-linux.en.html#ks959


Comment 3 Paul Osmialowski 2008-03-25 19:28:52 UTC
Upgrade to kernel-2.6.24.3-34.fc8 fixes the issue as this kernel contains
mentioned module.



Note You need to log in before you can comment on or make changes to this bug.