Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 289281 - Screen refresh problem
Summary: Screen refresh problem
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libgnomecanvas
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 307011 319651 319991 322391 346481 (view as bug list)
Depends On:
Blocks: F8Blocker
TreeView+ depends on / blocked
 
Reported: 2007-09-13 13:39 UTC by Andreas Thienemann
Modified: 2007-11-30 22:12 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-09 16:03:01 UTC


Attachments (Terms of Use)
"screenshot" (deleted)
2007-09-13 13:39 UTC, Andreas Thienemann
no flags Details

Description Andreas Thienemann 2007-09-13 13:39:52 UTC
using the rawhide installer from 20070913 the screen is not correctly refreshed
when showing the partition tools, leaving some text from the previous installer
screen in place.

mobile phone pic attached.

Comment 1 Andreas Thienemann 2007-09-13 13:39:52 UTC
Created attachment 194681 [details]
"screenshot"

Comment 2 Jeremy Katz 2007-09-21 17:53:16 UTC
I can reproduce this, but nothing about what we've done has changed here and I
can't see anything that would be explicitly causing this.  It looks like
something that's changed in either gtk or gnomecanvas that's likely tickling  this

Comment 3 Jeremy Katz 2007-09-24 00:00:23 UTC
And I had no luck on Friday afternoon with trying to get a more reasonable
reproducer than just anaconda :-/ 

Comment 4 Jeremy Katz 2007-09-26 14:01:03 UTC
*** Bug 307011 has been marked as a duplicate of this bug. ***

Comment 5 Jeremy Katz 2007-10-05 02:00:44 UTC
*** Bug 319651 has been marked as a duplicate of this bug. ***

Comment 6 Jeremy Katz 2007-10-05 13:31:40 UTC
*** Bug 319991 has been marked as a duplicate of this bug. ***

Comment 7 Jeremy Katz 2007-10-07 20:52:35 UTC
*** Bug 322391 has been marked as a duplicate of this bug. ***

Comment 8 Jeremy Katz 2007-10-07 20:54:02 UTC
Bumping to blocker status due to high visibility.

Comment 9 Jeremy Katz 2007-10-07 21:02:02 UTC
Doing some package bisecting, this breaks by moving from
libgnomecanvas-2.19.2-1.fc8 to libgnomecanvas-2.19.2-2.fc8.  Which points the
finger a bit at Federico's tearing patch that Ray added in that build.

Comment 10 Matthias Clasen 2007-10-09 03:52:15 UTC
yeah, a likely culprit

Comment 11 Matthias Clasen 2007-10-09 16:03:01 UTC
Removed the patch in 2.20.0-2.fc8. Please reopen if that doesn't fix it.

Comment 12 Jeremy Katz 2007-10-23 14:10:23 UTC
*** Bug 346481 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.