Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2883 - the bash process started with xterm dont die when X server is killed.
Summary: the bash process started with xterm dont die when X server is killed.
Keywords:
Status: CLOSED DUPLICATE of bug 2767
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: distribution
Version: 6.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-17 19:01 UTC by n.lathiotakis
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-19 14:39:20 UTC


Attachments (Terms of Use)

Description n.lathiotakis 1999-05-17 19:01:46 UTC
After leaving the xsession all processes started within it
should be also killed. Thats not true for the bash started
with xterm. I usually have 5-6 xterms on my xsession and
after a few rounds of stop
and start the X there were some tenths of 'bash' still
running.

Of course you can always kill them, either manually or using
a script, or there must be a way to prevent that happening.
But, it should not happen by default and for a novice user
thats not a nice behaviour since after some period of
continuous
uptime the number of processes will exceed the limit.

Comment 1 Raul Acevedo 1999-05-18 21:10:59 UTC
I believe this is a dup of bug #2767, which I entered on 5/14/99.

I don't know if this is related, but I've noticed that if you start
an xterm without the "&" (i.e. it's in the shell foreground), then
hit Ctrl-c, it won't die, but it will freeze up.  I'm almost 100%
sure that this situation should, and normally does, just kill the
xterm.

Comment 2 Jay Turner 1999-05-19 14:39:59 UTC
*** This bug has been marked as a duplicate of 2767 ***


Note You need to log in before you can comment on or make changes to this bug.