Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2880 - kickstart installation -- rootpw --iscrypted is broken
Summary: kickstart installation -- rootpw --iscrypted is broken
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-17 18:04 UTC by justin
Modified: 2015-06-09 16:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-15 22:30:51 UTC


Attachments (Terms of Use)

Description justin 1999-05-17 18:04:55 UTC
rootpw --iscrypted somecryptedpasswd does not work

It's supposed to put that string, verbatim, into root's
password entry in /etc/passwd.  When booting from
a rescue disk I discovered that it places a
different string there.

This worked correctly under 5.2.

This is a show-stopper for us, and is preventing us
from installing Redhat Linux 6.0 across our installation.

Comment 1 David Lawrence 1999-05-17 23:13:59 UTC
This has been verified to be a problem.

Comment 2 Matt Wilson 1999-05-28 23:51:59 UTC
*** Bug 2460 has been marked as a duplicate of this bug. ***

When using kickstart to install a machine, I used an already
encrypted password. When it rebooted I couldn't log in as
root. After some investigating, I found out if I presented
the password hash I had specified in the kickstart file, it
would then let me log in.

In other words, during the install, the encrypted password
was encrypted again.

------- Additional Comments From gordon.m.tetlow@vanderbilt.edu  05/01/99 02:29 -------
I checked the value of skipCrypt and found it to be 0 after the call
to poptGetContext inside of setRootPassword inside install2.c

This seems to be the problem, although why the poptGetContext is
returning skipCrypt as 0 is beyond me.

Gordon

------- Additional Comments From dkl@redhat.com  05/10/99 15:52 -------
I have verified this on a test lab machine.

------- Additional Comments From dkl@redhat.com  05/10/99 15:54 -------


*** Bug 2627 has been marked as a duplicate of this bug. ***


When doing a kickstart installation with RedHat 6.0
(kickstart is great!) and writing something like

rootpw --iscrypted 8d78LWoez74ef

in the kickstart file sets the root password to "8d78LWoe".
--iscrypted still worked in 5.2.  I quickly looked through
the code in install2, but there were little changes in
the password code, so I could not figure the problem out.
I have --useshadow in auth config.

------- Email Received From  Justin Sheehy <justin@linus.mitre.org> 06/15/99 10:22 -------

Comment 3 David Lawrence 1999-06-17 22:58:59 UTC
*** Bug 3517 has been marked as a duplicate of this bug. ***

In ref to Bug 2640. This still appears to be a problem. I
have downloaded the new bootnet.img from updates.redhat.com
and am still seeing the same problem.

------- Additional Comments From msmith@exodus.net  06/17/99 13:23 -------
Sorry ref to Bug 2460

Comment 4 Bill Nottingham 1999-07-15 22:30:59 UTC
*** This bug has been marked as a duplicate of 3970 ***

Comment 5 openshift-github-bot 2015-06-09 16:04:56 UTC
Commits pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/867dc829c199fa36a2daca3aea4ae4a1a884c8d5
Issue 2880 - allow debugging docker push command.

https://github.com/openshift/origin/commit/1010dbdc5ca7375e18fcdd4b02dbc1f730adfff5
Merge pull request #2953 from soltysh/issue2880

Merged by openshift-bot


Note You need to log in before you can comment on or make changes to this bug.