Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 283291 - hp-toolbox fails without xsane installed
Summary: hp-toolbox fails without xsane installed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: 7
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F7Update
TreeView+ depends on / blocked
 
Reported: 2007-09-07 22:36 UTC by Kent Pirkle
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 1.7.4a-5.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-11 01:47:20 UTC


Attachments (Terms of Use)

Description Kent Pirkle 2007-09-07 22:36:25 UTC
Description of problem:

hp-toolbox gui fails to start


Version-Release number of selected component (if applicable):

AttributeError: 'UserSettings' object has no attribute 'cmd_scan'

How reproducible:

Everytime


Steps to Reproduce:
1. /usr/bin/hp-toolbox
2.
3.
  
Actual results:

$ /usr/bin/hp-toolbox 

HP Linux Imaging and Printing System (ver. 1.7.4a)
HP Device Manager ver. 10.0

Copyright (c) 2001-7 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Traceback (most recent call last):
  File "/usr/bin/hp-toolbox", line 159, in <module>
    toolbox = DevMgr4(hpiod_sock, hpssd_sock, toolboxCleanup, __version__)
  File "/usr/share/hplip/ui/devmgr4.py", line 152, in __init__
    self.user_settings = utils.UserSettings()
  File "/usr/share/hplip/base/utils.py", line 541, in __init__
    self.load()
  File "/usr/share/hplip/base/utils.py", line 643, in load
    self.cmd_scan = user_cfg.commands.scan or self.cmd_scan
AttributeError: 'UserSettings' object has no attribute 'cmd_scan'


Expected results:

GUI should start

Additional info:

Comment 1 Tim Waugh 2007-09-10 09:07:22 UTC
I think this is because there are no scanning tools installed.  If you run 'yum
install xsane' to install one, does hp-toolbox start correctly?

Comment 2 Kent Pirkle 2007-09-10 10:59:25 UTC
Yep, that was it, I installed xsane and the hp-toolbox gui came up. Thanks!

Comment 3 Tim Waugh 2007-09-10 11:15:31 UTC
Great.  I found a fix that went into HPLIP 2.7.7 that's relevant to this, and
I've backported it to the F-7 package.  If I do another HPLIP update for F-7,
this will get in.

Comment 4 Fedora Update System 2007-10-11 01:47:17 UTC
hplip-1.7.4a-5.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.