Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2822 - need summary
Summary: need summary
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: egcs
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
: 2825 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-14 16:20 UTC by Red Hat Bugzilla
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-14 17:39:47 UTC


Attachments (Terms of Use)

Description Red Hat Bugzilla 1999-05-14 16:20:42 UTC
Despite the egcs-c++ package description, the shared
libstdc++ is included. It ought to be in the libstdc++
package only:

  rpm -qf /usr/lib/libstdc++-2-libc6.1-1-2.9.0.so
  egcs-c++-1.1.2-12
  libstdc++-2.9.0-12

  egcs-c++
  It does include the static standard C++ library and
  C++ header files; the library for dynamically linking
  programs is available separately.

Due to dependencies one cannot remove the libstdc++ package,
but one can remove the egcs-c++ package (*without* --nodeps)
which in turn will remove the shared library and thus breaks
any depending programs:

  rpm -e libstdc++
  error: removing these packages would break dependencies:
    [snip]

  rpm -e egcs-c++
    [/usr/lib/libstdc++-2-libc6.1-1-2.9.0.so now gone]

  kwm
  kwm: error in loading shared libraries:
libstdc++-libc6.1-1.so.2:
  cannot open shared object file: No such file or directory

Comment 1 Red Hat Bugzilla 1999-05-14 17:35:59 UTC
it's an RPM bug that removing one removes the shared file - it's
being worked on.

Comment 2 Red Hat Bugzilla 1999-05-14 17:39:59 UTC
fixed in rpm-3.0.1-9, available in today's rawhide.

Comment 3 Red Hat Bugzilla 1999-05-14 19:23:59 UTC
*** Bug 2825 has been marked as a duplicate of this bug. ***

My solution was to uninstall all tetex* RPMs and reinstall
them.  uninstall complained about not being able to delete
many files.


Note You need to log in before you can comment on or make changes to this bug.