Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 281401 - rpmbuild --target i686 creates package with --libdir=/usr/lib64
Summary: rpmbuild --target i686 creates package with --libdir=/usr/lib64
Keywords:
Status: CLOSED DUPLICATE of bug 232429
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-06 20:34 UTC by Peter Kovář
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-24 11:51:10 UTC


Attachments (Terms of Use)

Description Peter Kovář 2007-09-06 20:34:54 UTC
Description of problem:
rpmbuild with --target i686 creates correct 32 bit binaries and libraries but
libdir variable points to /usr/lib64 instead of /usr/lib

Version-Release number of selected component (if applicable):
rpm-build-4.4.2.2-0.1.rc1

How reproducible:
Always

Steps to Reproduce:
rpmbuild -bb --target i686 /usr/src/redhat/SPECS/flac.spec
Building target platforms: i686
Building for target i686

+ ./configure --build=x86_64-redhat-linux-gnu --host=x86_64-redhat-linux-gnu
--target=i686-redhat-linux-gnu --program-prefix= --prefix=/usr
--exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc
--datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib64
--libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com
--mandir=/usr/share/man --infodir=/usr/share/info --with-pic

/bin/sh ../../libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I../..
      -I../.. -I./include -I../../include -DNDEBUG -O3 -funroll-loops
-finline-functions -Wall -W -Winline -DFLaC__INLINE=__inline__ -O2 -g -pipe
-Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i686 -mtune=generic
-fasynchronous-unwind-tables -MT bitmath.lo -MD -MP -MF .deps/bitmath.Tpo -c -o
bitmath.lo bitmath.c

rpm -qilp /usr/src/redhat/RPMS/i686/flac-1.1.4-5.fc8.i686.rpm
/usr/lib64/libFLAC++.so.6
/usr/lib64/libFLAC++.so.6.0.1
/usr/lib64/libFLAC.so.8
/usr/lib64/libFLAC.so.8.0.1

Actual results:
--libdir=/usr/lib64

Expected results:
--libdir=/usr/lib

Additional info:
rpm-build compnent is missing in bugzilla, so I've chosen rpm

Comment 1 Peter Kovář 2007-09-06 21:26:48 UTC
Recent RPM 4.4.90 from http://hg.rpm.org/rpm shows the same problem.

What year is now?

Shame!

Peter Kovář
50 65 74 65 72 20 4B 6F 76 C3 A1 C5 99


Comment 2 Jeff Johnson 2007-09-07 00:44:32 UTC
This is fixed over a year now in rpm-4.5.7+.

But if you insist on using rpm-4.4.2 from rpm.org, the answer is to edit
/etc/rpm/platform, and change the arch to one that supports 64 bit builds.

Comment 3 Jeff Johnson 2007-09-07 00:44:49 UTC
Apologies, 4.4.7+.

Comment 4 Panu Matilainen 2007-10-24 11:51:10 UTC

*** This bug has been marked as a duplicate of 232429 ***


Note You need to log in before you can comment on or make changes to this bug.