Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2810 - pgaccess dies on startup
Summary: pgaccess dies on startup
Keywords:
Status: CLOSED DUPLICATE of bug 2698
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: postgresql
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-14 05:58 UTC by John Morris
Modified: 2015-01-07 23:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-14 14:49:34 UTC


Attachments (Terms of Use)

Description John Morris 1999-05-14 05:58:38 UTC
Error in startup script: couldn't load file "libpgtcl.so":
/usr/lib/libpgtcl.so: undefined symbol: crypt

The docs for pgaccess mention that things have to be changed
in makefiles.  Here is the relevent section from the docs
for pgaccess:

   PostgreSQL 6.4 release has a minor bug. I does not includ
by default the crypt lib
when compiling libpgtcl. So, you will need to manually add a
-lcrypt to SHLIB line in
Makefile in src/interfaces/libpgtcl and then make clean and
make again. The new
libpgtcl.so library is properly configured to run pgaccess.

Comment 1 Jeff Johnson 1999-05-14 14:49:59 UTC
*** This bug has been marked as a duplicate of 2698 ***


Note You need to log in before you can comment on or make changes to this bug.