Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2783 - suspend/resume causes clocks to get set forward
Summary: suspend/resume causes clocks to get set forward
Keywords:
Status: CLOSED DUPLICATE of bug 2396
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: clock
Version: 6.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-13 02:35 UTC by Yaron Minsky
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-14 20:24:06 UTC


Attachments (Terms of Use)

Description Yaron Minsky 1999-05-13 02:35:40 UTC
My machine is a regular desktop, but I have power-saving
settings currently on (in my BIOS).  Whenver the machine
goes into suspend mode and comes back, the clock is set
forward.  I'm not sure what the magic formula is --
sometimes it seems to be set forward 20 minutes, sometimes 4
hours.

The only workaround I can figure out at the moment is to
disable energy-saving mode from the BIOS.

Comment 1 Yaron Minsky 1999-05-13 02:43:59 UTC
Further information about the bug:  it appears that what happens is
that when the resume occurs, the timezone is ignored and the hwclock
value is directly set to the real clock value.  That, at least,
explains the cases I've run up against with the 4 hour move.  I'm not
sure about the 30-minute shift, but I can't replicate that one yet
anyway.

Comment 2 Bill Nottingham 1999-05-13 14:15:59 UTC
Try grabbing the latest apmd package from Raw Hide; alternatively,
start apmd with the '-u' option if your system clock is
in UTC. Does that help?

Comment 3 Yaron Minsky 1999-05-13 17:37:59 UTC
I switched over to storing my clock in regular time, not UTC (using
linuxconf) and the problem still persists, sort of.  Now, when I do
apm -s, it wakes up with the right time, but when I do apm -S, it
wakes up with the time set BACK by four hours.  This is with the
newest apm installed from the updates directory.  I haven't tried the
RawHide package.  The command line invocation for apmd (according to
ps) is:

    /usr/sbin/apmd -p 10 -w 5 -W

Comment 4 Yaron Minsky 1999-05-14 01:41:59 UTC
One more addition:  When time is stored as UTC, then:
  return from apm -s sets time FORWARD four hours
  return from apm -S doesn't mess up the clock

when time is not stored as UTC, then:
  return from apm -s doesn't mess up clock
  return from apm -S sets clock four hours BACKWARDS

This would suggest that restoring from apm -s always assumes non-UTC,
and restoring from apm -S always assumes UTC.  But this is almost too
odd to believe.

Comment 5 Jeff Johnson 1999-05-14 20:24:59 UTC
*** This bug has been marked as a duplicate of 2396 ***


Note You need to log in before you can comment on or make changes to this bug.