Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2780 - gnome-linuxconf tabs genrate imlib errors
Summary: gnome-linuxconf tabs genrate imlib errors
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-12 23:06 UTC by nihility
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-28 20:11:44 UTC


Attachments (Terms of Use)

Description nihility 1999-05-12 23:06:20 UTC
in the gnome interface of linuxconf, selecting multiple
options causes the tab redraws to be INCREDIBLY slow ... i
ran linuxconf from a terminal, and dicovered it was
genrating several repeating imlib errors ... they are as
follows:

Error message from remadmin :IMLIB ERROR: SHM can't get SHM
Identifier for Shared XImage
Error message from remadmin :             Falling back on
XImages
Error message from remadmin :IMLIB ERROR: SHM can't get SHM
Identifier for Shared Pixmap Wrapper
Error message from remadmin :             Falling back on
Shared XImages

this pretty much makes the gnome-linuxconf module not very
usable

Comment 1 Hardy Mayer 1999-05-20 18:15:59 UTC
In addition, gnome-linuxconfig rewrites my sendmail.cf file
and makes some unwanted modifications in it).  For example
it removes localhost from the DH entry, so I cant read the POP mail
fetched from  my office machine.

Comment 2 Hardy Mayer 1999-05-20 18:16:59 UTC
In addition, gnome-linuxconfig rewrites my sendmail.cf file
and makes some unwanted modifications in it).  For example
it removes localhost from the DH entry, so I cant read the POP mail
fetched from  my office machine.

Comment 3 Michael K. Johnson 1999-08-28 20:11:59 UTC
I can't reproduce the first problem; however, gnome-libs-1.0.14 has
some imlib changes in it, so perhaps our next release, which I
expect to have gnome-libs-1.0.14 or later, will fix this for you
"magically".  I've marked this as "NEXTRELEASE" in the hope that
gnome-libs-1.0.14 fixes this; if it isn't true, please re-open the
bug report.

As far as editing sendmail.cf, you can disable the mailconf
module and then linuxconf won't touch sendmail.cf any more.
linuxconf won't modify it at all in the first place unless
you use mailconf to set up an initial configuration, but
then it does NOT try to parse sendmail.cf to see what changes
you made, because sendmail.cf syntax is rather on the complex
side...

------- Additional Comments From   10/03/99 11:08 -------
About the imlib errors: This only seems to happen if you run
linuxconf from a non-gnome window manager.
(For instance, xinit and twm).


Note You need to log in before you can comment on or make changes to this bug.