Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2764 - _PATH_MAILDIR is /var/mail, should be /var/spool/mail
Summary: _PATH_MAILDIR is /var/mail, should be /var/spool/mail
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
: 2730 4722 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-12 15:14 UTC by Jeff Johnson
Modified: 2008-05-01 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-02 22:00:18 UTC


Attachments (Terms of Use)

Description Jeff Johnson 1999-05-12 15:14:36 UTC
_PATH_MAILDIR on i386 (but not sparc) is set incorrectly
to /var/mail. This causes finger (and kbiff) to look in the
wrong directory for incoming mail.

Comment 1 Jeff Johnson 1999-05-12 15:16:59 UTC
*** Bug 2730 has been marked as a duplicate of this bug. ***

when checking for a users' mail status finger expects the
mailfiles in /var/mail instead of /var/spool/mail

Comment 2 Cristian Gafton 1999-07-02 22:00:59 UTC
This is fixed in the glibc 2.1.2 package. finger will have to be
recompiled, though.

The new glibc rpm will be available in rawhide shortly.

Comment 3 Jeff Johnson 1999-08-26 14:05:59 UTC
*** Bug 4722 has been marked as a duplicate of this bug. ***

Both finger and fingerd from new RH 6.0 packages
(finger-0.10-24) search for user mailboxes in /var/mail, not
in /var/spool/mail as it was on RH 5.2 (0.10-5). This occurs
in local use as well as in remote user@server use.
The only thing strace showed me was
stat("/var/mail/jmeno", 0xbffffb68)     = -1 ENOENT (No such
file or directory)


Note You need to log in before you can comment on or make changes to this bug.