Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 274631 - NoDisplay=True defined in some of OpenOffice.org's/LibreOffice desktop entries
Summary: NoDisplay=True defined in some of OpenOffice.org's/LibreOffice desktop entries
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: rawhide
Hardware: All
OS: All
medium
low
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 737211 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-02 17:33 UTC by Stewart Adam
Modified: 2011-11-04 10:04 UTC (History)
5 users (show)

Fixed In Version: libreoffice-3.4.3.2-8.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-09-03 07:21:07 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 41681 None None None Never

Description Stewart Adam 2007-09-02 17:33:43 UTC
Description of problem:
NoDisplay=True is present in the math openoffice.org desktop files, making that
module of openoffice.org inaccessible from the menu. For example, to start a
drawing, one must start the 

Version-Release number of selected component (if applicable):
openoffice.org-core-2.2.1-18.8.fc8
openoffice.org-draw-2.2.1-18.8.fc8
openoffice.org-math-2.2.1-18.8.fc8
openoffice.org-calc-2.2.1-18.8.fc8

How reproducible:
Always

Steps to Reproduce:
1. Look in the Applications > Office menu

Actual Results:
Menu entries are not visible

Expected Results:
Installed modules appear in the menus

Comment 1 Caolan McNamara 2007-09-03 07:21:07 UTC
It's deliberate, the UI/UE team decided on which components should be considered
toplevel and visible in the menus, and which ones are to be considered
subcomponents that are typically used inside documents and don't need toplevel
menus.

*** This bug has been marked as a duplicate of 156677 ***

Comment 2 David Tardon 2011-09-10 07:20:28 UTC
*** Bug 737211 has been marked as a duplicate of this bug. ***

Comment 3 fer 2011-09-10 21:39:35 UTC
Well, for me this is then a deliberated "BUG".

What made the UI/UE team think that it is the user desire ?
I have used libreoffice-math dayly. And then, my app reads the saved .odf files.

Now, after each "yum update libreoffice", i need to edit the .desktop file and set NoDisplay=False.

Have someone reporting a bug that libreoffice-math IS on menu ?

There is no other way to make this change persistent, like a .rc file ?

Think UI/UE team, Think !

Comment 4 David Tardon 2011-09-12 04:32:53 UTC
> There is no other way to make this change persistent, like a .rc file ?

cp /usr/share/applications/libreoffice-math.desktop ~/.local/share/applications/
sed -i -e /NoDisplay/d ~/.local/share/applications/libreoffice-math.desktop

Comment 5 fer 2011-09-12 19:50:48 UTC
Thanks, David !

But i fear the copy on .local folder came to be out to date, if libreoffice developers make some change in original libreoffice-math.desktop.

Anyway, very thanks.

Comment 6 Caolan McNamara 2011-09-13 10:43:34 UTC
alright, let's take pity on this stuff. Given the changes in gnome3 and all the intervening change in attitudes towards a "fedora core" of minimal menus etc it doesn't make a lot of sense to single out poor little math to be hidden from the default menus anymore, so let's restore "math.desktop"

Comment 7 fer 2011-09-14 06:33:13 UTC
HURRAY !

Long live to "math".

Comment 8 David Tardon 2011-11-04 08:22:28 UTC
note that upstream added NoDisplay=true to math.desktop recently

Comment 9 Caolan McNamara 2011-11-04 10:04:29 UTC
The irony.


Note You need to log in before you can comment on or make changes to this bug.