Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2736 - meta key doesn't get converted in bash under Xterm
Summary: meta key doesn't get converted in bash under Xterm
Keywords:
Status: CLOSED DUPLICATE of bug 2738
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-11 16:21 UTC by thoth
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-15 20:31:59 UTC


Attachments (Terms of Use)

Description thoth 1999-05-11 16:21:37 UTC
After upgrading from 5.2 to 6.0 I encountered this very
annoying problem.  At console, Alt-b is backward word.  In
an Xterm, it inserts itself.  Creating a .inputrc containing

set convert-meta On

does not cause subsequent xterms to behave properly.  nxterm
exhibits the same problem.  ESC-b behaves properly in all
settings.

 frop:11 $ echo $SHELL
/bin/bash
 frop:12 $ echo $BASH_VERSION
1.14.7(1)
 frop:13 $ rpm -q bash
bash-1.14.7-16
 frop:16 $ rpm -q -f /usr/X11R6/bin/xterm
XFree86-3.3.3.1-49

Comment 1 Jeff Johnson 1999-05-15 20:31:59 UTC
*** This bug has been marked as a duplicate of 2738 ***


Note You need to log in before you can comment on or make changes to this bug.