Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2724 - network --bootproto static fails in kickstart
Summary: network --bootproto static fails in kickstart
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-11 01:49 UTC by adam
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-07 15:10:02 UTC


Attachments (Terms of Use)

Description adam 1999-05-11 01:49:12 UTC
When doing a kickstart install, using a DHCP/NFS combination
for the install, if the kickstart file specifies network
--bootproto static in the config file, the installer fails
to change the ethernet config from BOOTP/DHCP to static.

Relevant bits of the kickstart file follows:

network --bootproto static --ip 162.42.150.62 --netmask
255.255.255.0 --gateway 162.42.150.1 --nameserver
162.42.150.33
(all on one line, of course)

After a reboot, you will notice that the
/etc/sysconfig/network and
/etc/sysconfig/network-scripts/ifcfg-eth0 files have failed
to change to static from BOOTP/DHCP.

Adam

Comment 1 Jay Turner 1999-07-07 15:10:59 UTC
*** This bug has been marked as a duplicate of 192 ***


Note You need to log in before you can comment on or make changes to this bug.