Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2722 - chown/chgrp different behavior on bad symlinks
Summary: chown/chgrp different behavior on bad symlinks
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: fileutils
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
: 2374 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-10 21:03 UTC by Cristian Gafton
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-04 16:37:10 UTC


Attachments (Terms of Use)

Description Cristian Gafton 1999-05-10 21:03:09 UTC
chown -f exits with a 0 on a bad symlink
chgrp -f does not

Comment 1 Jeff Johnson 1999-05-11 14:51:59 UTC
*** Bug 2374 has been marked as a duplicate of this bug. ***

the fixperms macro bombs out if chown or chgrp fails.  This
isn't the behaviour that RPM 2.5 had.  While it is only a
configuration issue, it seems to make sense to me that the
default behaviour is to be backwards compatible with 2.5.

Comment 2 Cristian Gafton 2001-02-08 00:35:04 UTC
Seems to work since at least 6.2...


Note You need to log in before you can comment on or make changes to this bug.