Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2721 - You left the postgresql data rpm out of RedHat 6.0
Summary: You left the postgresql data rpm out of RedHat 6.0
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: postgresql
Version: 6.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
: 2775 3237 3601 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-10 20:39 UTC by aardvark
Modified: 2015-01-07 23:37 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-13 14:22:44 UTC


Attachments (Terms of Use)

Description aardvark 1999-05-10 20:39:04 UTC
Without the data rpm, postgresql won't run.

Comment 1 Bill Nottingham 1999-05-13 14:18:59 UTC
*** Bug 2775 has been marked as a duplicate of this bug. ***

The postgresql-data rpm that I have always seen on previous
releases of your software is not on the 6.0 CD. When
postgresql is started it aborts with an error about no data
directory, so I assume these two things are related. I
downloaded an rpm for postgresql-data from rufus.w3.com and
installed it. Now postgresql works as expected. Just thought
you should know

Comment 2 Bill Nottingham 1999-05-13 14:21:59 UTC
(explanation courtesy Cristian Gafton)

You have to become the postgres user and then run
initdb:                         su -
postgres
PGDATA=/var/lib/pgsql PGLIB=/usr/lib/pgsql initdb

The data files are no longer shipped because you donit want us
replacing your databases with the empty, default ones on updates.
Because of this we've made the postgres RPMs "no know anything" about
the data files, thus avoiding touching those on upgrades.

I know we used to ship those, but that proved to be a bad idea.

Comment 3 Bill Nottingham 1999-05-13 14:22:59 UTC
in case the formatting is confusing, the command is:

su - postgres
PGDATA=/var/lib/pgsql PGLIB=/usr/lib/pgsql initdb

Comment 4 Jeff Johnson 1999-06-03 14:12:59 UTC
*** Bug 3237 has been marked as a duplicate of this bug. ***

Package previously shipped with a 4 rpm set. This RPM is
necessary to set up the default database.

Comment 5 Jeff Johnson 1999-06-21 08:51:59 UTC
*** Bug 3601 has been marked as a duplicate of this bug. ***

RedHat 6.0 contains
postgresql-6.4.2-3.i386.rpm
postgresql-clients-6.4.2-3.i386.rpm
postgresql-devel-6.4.2-3.i386.rpm

but not

postgresql-data-6.4.2-4.i386.rpm
which is necessary to get it up and running.


Note You need to log in before you can comment on or make changes to this bug.