Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 271 - RedHat/Window Operations/Move will instantly close X session
Summary: RedHat/Window Operations/Move will instantly close X session
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: fvwm2
Version: 5.2
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-12-02 22:59 UTC by John Morris
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1998-12-16 17:22:52 UTC


Attachments (Terms of Use)

Description John Morris 1998-12-02 22:59:35 UTC
The above sequence reliably closes out an X session, but if
you click on the desktop and pick move it will work
correctly.  This is repeatable and has been tested on at
least three freshly installed RH5.2 boxen with two different
video cards/X servers (XF86_S3V and XSUSE_Matrox).  Don't
know enough to fix it but I can at least report it.  :)

I set severity to High since it nukes your session taking
out any running apps/unsaved data.

Comment 1 Derek Tattersall 1998-12-08 15:24:59 UTC
Let us know whick WM you are using, as well as exactly what steps
cause X to crash out.

Comment 2 Aleksey Nogin 1998-12-09 00:41:59 UTC
I can confirm that bug exists in RH 5.1 and I also remember similar
problems with RH 5.0

In 5.1:
1) Start X
2) Press "Start" button in the FVWMTaskBar
3) Choose Window Operations|Move
4) Go to some window and press the middle mouse button

At this moment fvwm2 would coredump:

gulag|~>gdb -core core /usr/X11R6/bin/fvwm2
GNU gdb 4.17
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and
you are
welcome to change it and/or distribute copies of it under certain
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for
details.
This GDB was configured as "i386-redhat-linux"...(no debugging symbols
found)...
Core was generated by `fvwm2 -cmd FvwmM4 -debug
/etc/X11/AnotherLevel/fvwm2rc.m4 -s'.
Program terminated with signal 11, Segmentation fault.
find_solib: Can't read pathname for load map: Input/output error

#0  0x80607cd in _start ()
(gdb) bt
#0  0x80607cd in _start ()
#1  0x80ce454 in ?? ()
#2  0x8058d2a in _start ()
#3  0x8055df9 in _start ()
#4  0x8058d2a in _start ()
#5  0x805d61e in _start ()
#6  0x805c708 in _start ()
#7  0x805d2c8 in _start ()
#8  0x805d6b8 in _start ()
#9  0x805c708 in _start ()
#10 0x805124a in _start ()
#11 0x8058d2a in _start ()
#12 0x805fdb5 in _start ()
#13 0x8058843 in _start ()
#14 0x8056e6a in _start ()
#15 0x80597f9 in _start ()

I have:
fvwm2-2.0.46-10
glibc-2.0.7-19
XFree86-3.3.2.3-18
AnotherLevel-0.6.8-2
redhat-release-5.1-2

Comment 3 Jay Turner 1998-12-09 17:37:59 UTC
Unable to reproduce this with the 5.1 + updates as reported.  We found
that it did fail with RH4.2, though.

Comment 4 David Lawrence 1998-12-09 21:11:59 UTC
Was able to recreate problem after upgrading XFree86 to latest server.

Comment 5 Preston Brown 1998-12-16 17:22:59 UTC
bug has been fixed in an errata release of fvwm2.


Note You need to log in before you can comment on or make changes to this bug.