Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2698 - pgaccess does not work (probed on sparc and x86)
Summary: pgaccess does not work (probed on sparc and x86)
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: postgresql
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
: 2287 2810 2949 3617 4652 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-10 16:19 UTC by ipaul
Modified: 2008-05-01 15:37 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-21 19:56:12 UTC


Attachments (Terms of Use)

Description ipaul 1999-05-10 16:19:24 UTC
when I start pgaccess,I get the following error:

Error in startup script: couldn't load file "libpgtcl.so":
/usr/lib/libpgtcl.so: undefined symbol: crypt
    while executing
"load libpgtcl.so"
    (procedure "main" line 6)
    invoked from within

Comment 1 Jeff Johnson 1999-05-11 15:51:59 UTC
*** Bug 2287 has been marked as a duplicate of this bug. ***

pgaccess from postgresql-devel does not work.
Error in startup script: couldn't load file "libpgtcl.so":
/usr/lib/libpgtcl.so: undefined symbol: crypt
    while executing
"load libpgtcl.so"
    (procedure "main" line 6)
    invoked from within
"main $argc $argv"
    (file "/usr/bin/pgaccess" line 4954)

Comment 2 Jeff Johnson 1999-05-14 14:49:59 UTC
*** Bug 2810 has been marked as a duplicate of this bug. ***

Error in startup script: couldn't load file "libpgtcl.so":
/usr/lib/libpgtcl.so: undefined symbol: crypt

The docs for pgaccess mention that things have to be changed
in makefiles.  Here is the relevent section from the docs
for pgaccess:

   PostgreSQL 6.4 release has a minor bug. I does not includ
by default the crypt lib
when compiling libpgtcl. So, you will need to manually add a
-lcrypt to SHLIB line in
Makefile in src/interfaces/libpgtcl and then make clean and
make again. The new
libpgtcl.so library is properly configured to run pgaccess.

Comment 3 Jeff Johnson 1999-05-22 12:49:59 UTC
*** Bug 2949 has been marked as a duplicate of this bug. ***

When pgaccess is run the following error message is
displayed:

Error in startup script: couldn't load file "libpgtcl.so":
/usr/lib/libpgtcl.so: undefined symbol: crypt
    while executing
"load libpgtcl.so"
    (procedure "main" line 6)
    invoked from within
"main $argc $argv"
    (file "/usr/bin/pgaccess" line 4954)

It looks like the tcl interface to postgres wasn't built
quite right.

Comment 4 jgotts 1999-06-02 04:48:59 UTC
Please release a fixed RPM for this.  The fix below is correct and
trivial.

Comment 5 Jeff Johnson 1999-06-21 17:30:59 UTC
*** Bug 3617 has been marked as a duplicate of this bug. ***

In RH 6.0 with postgresql-clients 6.4.2 the "pgaccess"
tcl/tk program does not work. The cause seems to be a
problem with the libpgtcl.so library.
The output of an attempt to run pgaccess is as follows:

Error in startup script: couldn't load file "libpgtcl.so":
/usr/lib/libpgtcl.so: undefined symbol: crypt
    while executing
"load libpgtcl.so"
    (procedure "main" line 6)
    invoked from within
"main $argc $argv"
    (file "/usr/bin/pgaccess" line 4954)

Comment 6 Jeff Johnson 1999-08-23 16:47:59 UTC
*** Bug 4652 has been marked as a duplicate of this bug. ***

According to the web page above...

   PostgreSQL 6.4 release has a minor bug. I does not includ
by default the crypt lib when compiling libpgtcl. So, you
will need to manually add a -lcrypt to
SHLIB line in Makefile in src/interfaces/libpgtcl and then
make clean and make again. The new libpgtcl.so library is
properly configured to run pgaccess.

Comment 7 Jeff Johnson 1999-09-21 19:56:59 UTC
This should be fixed by postgresql-6.5.1-0.8 and later.


Note You need to log in before you can comment on or make changes to this bug.