Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2697 - fixing autoboot.bat
Summary: fixing autoboot.bat
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: aboot
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
: 2726 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-10 15:25 UTC by jmm
Modified: 2008-05-01 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-19 21:06:00 UTC


Attachments (Terms of Use)

Description jmm 1999-05-10 15:25:41 UTC
autoboot.bat doesn't work.  It has been broken by the split
from a single boot version into two versions (local and
network).  It runs a command (one line):

   loadlin autoboot\vmlinuz
       initrd=..\misc\src\trees\initrd.img

(That was from memory, so it might be wrong. :-)  The trees
directory contains "initrd-l.img" and "initrd-n.img" for
local and network versions.

As a workaround, type the command by hand, using the right
filename, instead of using autoboot.bat to type the command
for you.

Comment 1 Jay Turner 1999-05-10 15:32:59 UTC
*** Bug 2584 has been marked as a duplicate of this bug. ***

Date: Wed, 5 May 1999 19:28:25 -0400 (EDT)
From: Bradley Glonka <bradley@linuxcentral.com>
To: bugs@redhat.com
Subject: Autoboot.bat -> bad initrd


RE: Red Hat 6.0

The autoboot.bat file points to a missing initrd image.


--
Brad


------- Additional Comments From dkl@redhat.com  05/06/99 13:08 -------
This has been verified to be true on a test lab machine.

Comment 2 Bill Nottingham 1999-05-11 14:18:59 UTC
*** Bug 2726 has been marked as a duplicate of this bug. ***

autoboot.bat on the RH 6.0 cd i bought today @ compusa does
not work.  i fixed the 'problem' by editing it to :

pushd e:\
e:\dosutils\loadlin e:\dosutils\autoboot\vmlinuz
initrd=e:\dosutils\autoboot\initrd.img
popd

(using 4dos, on a windoze98 box)

this allowed me to run the install just fine from the cdrom.

thanks,

furlan

fprimus@primusic.freeservers.com
fprimus@phil-n-le-blanc.com

Comment 3 Bill Nottingham 1999-05-14 14:30:59 UTC
*** Bug 2814 has been marked as a duplicate of this bug. ***

This may seem nit-picky, but on one of my sytems that I
routinely test stuff on (instead of using a production
machine) will not load the boot disk (not RedHat's fault).
So instead, I install a DOS disk with CDROM support and use
autoboot.bat.

That being said, I picked up RH6.0 from Fry's the other day
(at a VERY high price -- I'm shocked!!!) and attempted to
install it tonight.  My first try at "autoboot" failed
because it could not find the specified image.  I listed
the batch file to see what was being done.  I checked the
directory specified for the file indicated and it wasn't
there.  There were two other files with similar names so I
selected one and manually entered the command line.  The
installation started in a flash.

Someone forgot to update the DOSUTILS directory on the
CD. :)

Okay now that I have pointed out that flaw, do I get a new
copy of the CD when/if it's fixed? :)

Comment 4 Bill Nottingham 1999-08-19 21:06:59 UTC
fixed in Raw Hide...


Note You need to log in before you can comment on or make changes to this bug.