Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2694 - Root device can not contain install files.
Summary: Root device can not contain install files.
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.0
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 1999-05-10 14:14 UTC by jrm
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 1999-05-10 15:59:32 UTC

Attachments (Terms of Use)

Description jrm 1999-05-10 14:14:54 UTC
I tried originally to upgrade Redhat 6.0 using files in the
root partition to upgrade the same partition.  It failed
with a couldn't find RPM database error on the main screen.
I rebooted and tried rpm --rebuild after upgrading to the
Redhat 6.0 version of rpm.  This did not help.  Then I
noticed on the other screen the error regarding a mount on
/tmp/hdimage.  So I copied all the files to another
partition and got much further (till the problem I worked
around in bugid 2506.  Has anyone been able to use the same
partition to upgrade itself?

I only have a single root partition, no other partitions.

Another note:  bugid 2142 seems to mention this problem in
the last comment but I think their other primary issue was
resolved and so it was closed.

Comment 1 Bill Nottingham 1999-05-10 15:59:59 UTC
*** This bug has been marked as a duplicate of 2504 ***

Note You need to log in before you can comment on or make changes to this bug.