Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 26850 - wrong exit code
Summary: wrong exit code
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard: Florence Gold
: 3179 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-09 18:40 UTC by Gerald Teschl
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2001-02-26 20:06:33 UTC


Attachments (Terms of Use)

Description Gerald Teschl 2001-02-09 18:40:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16-22 i686)


If I try to upgrada a bad package (e.g. incomplete download) rpm will give
the correct error, but the exit code is 0.

Reproducible: Always
Steps to Reproduce:
[root@soliton tmp]# touch glibc-2.2.1-6.i686.rpm; ls -l
glibc-2.2.1-6.i686.rpm
-rw-r--r--    1 root     root            0 Feb  9 19:46
glibc-2.2.1-6.i686.rpm
[root@soliton tmp]# rpm -U glibc-2.2.1-6.i686.rpm; echo $?
error: glibc-2.2.1-6.i686.rpm does not appear to be a RPM package
0
	

Expected Results:  exit code > 0

Comment 1 Glen Foster 2001-02-09 23:15:32 UTC
We (Red Hat) should really try to resolve this before next release.

Comment 2 Jeff Johnson 2001-02-10 15:28:10 UTC
Fixed in rpm-4.0.2-0.36.

Comment 3 Gerald Teschl 2001-02-12 10:11:08 UTC
BTW: Shouldnt it read "does not appear to be an RPM package"? (a-> an)

Comment 4 Jeff Johnson 2001-02-21 18:26:46 UTC
*** Bug 3179 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.