Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2677 - relaying denied from localhost
Summary: relaying denied from localhost
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sendmail
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
: 2678 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-09 01:49 UTC by jan
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-18 17:43:13 UTC


Attachments (Terms of Use)

Description jan 1999-05-09 01:49:26 UTC
mailhandlers like mh (used in emacs for instance), and exmh,
use sendmail.  In the default configuration of sendmail,
/etc/sendmail.cf should read the database corresponding to
/etc/mail/access and allow relaying of mail from localhost.
/etc/sendmail.cf is not properly configured, so that the
entries in /etc/mail/access are ignored and it is impossible
to send mail using the above mailhandlers.

P.S. reverting to RedHat 5.2's /etc/sendmail.cf and
regenerating ip_allow, name_allow, relay_allow in /etc/mail
is a workaround, but it is perhaps not as secure.

Comment 1 Jeff Johnson 1999-05-16 23:54:59 UTC
*** Bug 2678 has been marked as a duplicate of this bug. ***

mailhandlers like mh (used in emacs for instance), and exmh,
use sendmail.  In the default configuration of sendmail,
/etc/sendmail.cf should read the database corresponding to
/etc/mail/access and allow relaying of mail from localhost.
/etc/sendmail.cf is not properly configured, so that the
entries in /etc/mail/access are ignored and it is impossible
to send mail using the above mailhandlers.

P.S. reverting to RedHat 5.2's /etc/sendmail.cf and
regenerating ip_allow, name_allow, relay_allow in /etc/mail
is a workaround, but it is perhaps not as secure.

P.P.S. I note that bug 2400 reports the same symptoms.  The
working sendmail.cf is from the rpm 8.8.7-20, the sendmail
rpm in the redhat 6.0 distribution is 8.9.3-10.

Comment 2 Jay Turner 1999-05-26 17:46:59 UTC
This issue has been forwarded to a developer for further review.

Comment 3 Cristian Gafton 1999-06-18 17:43:59 UTC
This should have been fixed in the shipping Red Hat Linux 6.0.

Please reopen if that is not the case.


Note You need to log in before you can comment on or make changes to this bug.