Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2668 - Some PAP secrets need quoting
Summary: Some PAP secrets need quoting
Keywords:
Status: CLOSED DUPLICATE of bug 987
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
: 4753 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-08 19:54 UTC by danf
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-28 19:32:15 UTC


Attachments (Terms of Use)

Description danf 1999-05-08 19:54:47 UTC
A PAP password entered with gnome-linuxconf that contains an
octothorpe '#' character appears to cause pppd to truncate
the password, causing logins to fail. '#' (and maybe other
characters) must be backslash quoted in the
/etc/ppp/pap-secrets file.

Comment 1 Bill Nottingham 1999-08-27 23:07:59 UTC
*** Bug 4753 has been marked as a duplicate of this bug. ***

I am setting up a system that uses PPP to dial out to a
server.  To dial out through the PBX at that location, you
must dial a "#" first.  This character is a comment
character to the "chat" program if it is at the beginning of
a line, but not anywhere else on the line.  However,
linuxconf cannot handle the "#" in the dial string.  If I
put it in and save the interface and then go back in to the
interface configuration screen, the dial number is empty
(like linuxconf sees "#" as a comment anywhere and tosses
it).  It looks like linuxconf does not even save the dial
number; if I go in and manually edit
/etc/sysconfig/network-scripts/chat-ppp0, it just has a line
like:

'OK' 'ATDT'

and I have to manually put in the number to dial.  If I go
back in to linuxconf and do anything to the interface I have
to again manually put the number in.

Comment 2 Michael K. Johnson 1999-08-28 19:32:59 UTC
*** This bug has been marked as a duplicate of 987 ***


Note You need to log in before you can comment on or make changes to this bug.