Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 266 - IP masquerader doesn't work properly on high value ports
Summary: IP masquerader doesn't work properly on high value ports
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 5.2
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
: 279 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-12-02 20:08 UTC by ah313
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-29 15:43:51 UTC


Attachments (Terms of Use)

Description ah313 1998-12-02 20:08:48 UTC
When using a FTP client behind a IP masquerader, and
trying to connect to a FTP site that runs on port 41181,
the masquerader doesn't work properly.

Connection is established, but the FTP client just hangs.
IE: you cannot get a directory listing for example, or
do any other operations.  I haven't done extensive testing
to see what other ports it fails on, but I have a feeling
the IP masquerader does not work properly work on any
port beyond 32767 (2^15 - 1).  The machine behind the IP
masquerader was a Win95 running CuteFTP 2.6.  I also tried
the FTP client in the DOS prompt, and identical results.
Therefore I doubt this is a client problem.

Comment 1 Bill Nottingham 1998-12-03 19:08:59 UTC
*** Bug 279 has been marked as a duplicate of this bug. ***

Comment 2 Cristian Gafton 1999-07-29 15:43:59 UTC
Is this still valid for the 2.2 kernel?  Or is this happening because
passive FTP should have been used?

Reopen if still valid


Note You need to log in before you can comment on or make changes to this bug.