Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2655 - gdm fails to honor XDMCP requests!!
Summary: gdm fails to honor XDMCP requests!!
Keywords:
Status: CLOSED DUPLICATE of bug 2614
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gdm
Version: 6.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Mason
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-08 13:32 UTC by Chris Evans
Modified: 2015-06-04 04:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-31 13:37:05 UTC


Attachments (Terms of Use)

Description Chris Evans 1999-05-08 13:32:51 UTC
Hi

Install RH6.0, choose to "launch X by default" during the
install.

When you boot the new system, GNOME pops up with a login
dialog. So far so good.

Now switch to a virtual console and type

startx -- -query 127.0.0.1 :1

This command starts X but FAILS to get to a login screen!
This is quite serious :-)

Note, if I change /etc/X11/prefdm so it points to "xdm", the
above command works fine.

Another note: when using gdm, traffic sent to the XDMCP port
queues up and is never read. The port should either be
fixed, or disabled- if it isn't used it's a security concern
:-)

Comment 1 Michael K. Johnson 1999-05-10 22:47:59 UTC
The workaround for now is to enable debugging by changing
Enable=0 to Enable=1 in the [debug] section of /etc/X11/gdm/gdm.conf.
This is most certainly a workaround and not a bugfix...

The workaround does not fix the fact that it listens when not
configured to do xdmcp.

------- Additional Comments From   08/24/99 10:31 -------
A little extra info:  GDM will respond to XDMCP requests when they
are DIRECT or QUERY requests (sent to the specified host).   It fails
when the requests are of type BROADCAST.

Comment 2 Preston Brown 1999-08-31 13:37:59 UTC
*** This bug has been marked as a duplicate of 2614 ***

------- Additional Comments From   10/20/99 17:24 -------
Contrary to the orginal comments from Redhat, my workstation is not
responding to 'DIRECT or QUERY requests'.  I just picked up 6.1 last
night hoping that this (and other problems) were resolved and it is
not.  I have not tried the listed workaround.

-Bob

Comment 3 openshift-github-bot 2015-06-04 04:47:56 UTC
Commit pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/be2087170132387bd4771c103a774b5ce8f93ead
Fix issue#2655; bz1225410; rebase openshift-sdn Godeps


Note You need to log in before you can comment on or make changes to this bug.