Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2650 - Disk/partition sizing not done on upgrades/installs
Summary: Disk/partition sizing not done on upgrades/installs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-08 05:17 UTC by richardr
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-10 23:17:29 UTC


Attachments (Terms of Use)

Description richardr 1999-05-08 05:17:18 UTC
I recently upgraded from RH 5.2 to 6.0.  I had my drive
partitioned into three partitions /, /usr and /export.  On
upgrading, everything went smoothly, except when I tried to
invoke startx, I got a message that the svga server file
XF86SVGA*, was missing.  I looked in /usr (I don't remember
the rest of the path) and sure enough, it wasn't there.
When I checked how full everything was with df -k, the /usr
was at 100%.

I know it is difficlut to determine the required sizes
before installation or upgrade, but there must be a way to
do it.  I know that under Windows (sorry to mention that),
InstallShiled does tell you before it does anything if it is
short on room.

By the way, when I initially installed 5.2 on a virgin
drive, I ran out of room, but at least it complained about
it during the install (well, it really took some looking to
determine the cause of the obtuse message), but at least it
faile.

I understand from Robert Hart that this is a well known bug,
but I feel that if we are going to have a "killer" OS, then
things like this nees immediate attention.

Best regards and thanks for Linux --

Richard Ravich

Comment 1 David Lawrence 1999-05-10 23:17:59 UTC
Thank you for the suggestion. It has been noted and we are working to
improve this in upcoming releases. Some new code is in 6.0 to do
better space checking but unfortunately it is not perfect yet.


Note You need to log in before you can comment on or make changes to this bug.