Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2646 - inews or trn miscompiled...
Summary: inews or trn miscompiled...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: trn
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
: 2925 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-08 01:28 UTC by jeff
Modified: 2016-10-24 19:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-02 12:02:31 UTC


Attachments (Terms of Use)

Description jeff 1999-05-08 01:28:21 UTC
the package trn includes the program Pnews which
is afront end fro inews (it expects it to be
/usr/lib/news/inews)

however, the package inews installs /usr/bin/inews
not /usr/lib/news/inews and therefore trn is unable
to post news as it should.

Of course the fix is simple...
   mkdir /usr/lib/news
   ln -s /usr/bin/news/inews /usr/bin/inews
But then why do we have packages at all?
Please either recompile the inews or the trn news
package and distribute as an update.

you are also missing a selection for the inews
package on this bug submittal page.

Comment 1 Jeff Johnson 1999-05-19 15:17:59 UTC
*** Bug 2925 has been marked as a duplicate of this bug. ***

When posting trn (the Pnews program
needs /usr/lib/news/inews), but that lives under /usr/bin

Screen shot
  Check spelling, Send, Abort, Edit, or List? s
  /usr/bin/Pnews: /usr/lib/news/inews: No such file or
directory

Setting a symlink brings up another problem: you have to
have inn installed.

  Check spelling, Send, Abort, Edit, or List? s
  Cannot open /etc/news/inn.conf

apparently the inn and trn package don't have appropriate
dependencies set

------- Additional Comments From dlt@redhat.com  05/19/99 10:08 -------
Verified 19 MAY 1999 DLT, via attemted post to alt.test.

------- Additional Comments From dlt@redhat.com  05/19/99 10:09 -------
trn was Mike's package.  Assignment to Cristian in lieu of any other
choice.

Comment 2 Jeff Johnson 1999-06-02 12:02:59 UTC
Fixed in trn-3.6-17. Dependency info added in inn-2.2-11. Thanks
for the analysis.

Comment 3 openshift-github-bot 2016-10-24 19:03:06 UTC
Commit pushed to master at https://github.com/openshift/openshift-ansible

https://github.com/openshift/openshift-ansible/commit/9e8edbc4bdcbc3495f2ea86d5a12b15e13da47ac
Merge pull request #2650 from sdodson/issue2646

Enable dnsmasq service


Note You need to log in before you can comment on or make changes to this bug.