Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2634 - rc.sysinit calls wrong RAID binaries
Summary: rc.sysinit calls wrong RAID binaries
Keywords:
Status: CLOSED DUPLICATE of bug 2604
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 6.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-07 14:14 UTC by Michael Redinger
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-07 19:01:32 UTC


Attachments (Terms of Use)

Description Michael Redinger 1999-05-07 14:14:15 UTC
The new raidtools (0.90) used in RH 6.0 do not contain
raidadd and raidrun any longer. However, there are still
calls to these programs in rc.sysinit:

if [ -f /proc/mdstat -a -f /etc/raidtab -a -x /sbin/raidadd
]; then
	action "Starting up RAID devices" raidadd -a
	rc=$?

	if [ $rc = 0 ]; then
		raidrun -a
		rc=$?
	fi
	(...)


In order to make the script work this should be changed to
the following:

if [ -f /proc/mdstat -a -f /etc/raidtab -a -x
/sbin/raidstart ]; then
	action "Starting up RAID devices" raidstart --all
	rc=$?
	(...)

Comment 1 Bill Nottingham 1999-05-07 19:01:59 UTC
*** This bug has been marked as a duplicate of 2604 ***


Note You need to log in before you can comment on or make changes to this bug.