Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2629 - rpm-3.0 expands macros in %ifos too late
Summary: rpm-3.0 expands macros in %ifos too late
Keywords:
Status: CLOSED DUPLICATE of bug 2873
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL: Resent-Message-ID: <"r86zU.0.Oy4.XTCC...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-07 09:34 UTC by benedict
Modified: 2015-01-07 23:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-24 19:56:06 UTC


Attachments (Terms of Use)

Description benedict 1999-05-07 09:34:40 UTC
The following spec file snippet should echo twice when built
with buildos irix6.5 - in 3.0 it echos only once.

%prep

%define mymacro irix6.5

%ifos %{mymacro}
echo "Expansion of ifos %{mymacro} is OK"
%endif

%ifos iris6.5
echo "Expansion of ifos %{mymacro} is OK"
%endif

The output is

Executing: %prep
+ umask 022
+ cd /tmp/benedict/BUILD-test-3.0
+ echo Expansion of ifos irix6.5 is OK
Expansion of ifos irix6.5 is OK
+ exit 0

Comment 1 Jeff Johnson 1999-05-14 18:35:59 UTC
Macros are correctly expanded before processing %ifX statements.

Your example has a typo (iris6.5 vs. irix6.5), I can't tell which is
wrong without examining uname(2) strings on an SGI platform.

Please reopen this bug if there is still a problem.

Comment 2 benedict 1999-05-17 09:53:59 UTC
OK. Sorry about the typo.

Comment 3 benedict 1999-05-17 13:30:59 UTC
See Bug # 2873
    The original problem for me was that I did not get any warning
when I defined %irix6.x in a macro file - so I thought it was not
expanded when I used a conditional such as
    %ifos %{irix6.x}

Comment 4 Jeff Johnson 1999-05-24 19:56:59 UTC
*** This bug has been marked as a duplicate of 2873 ***


Note You need to log in before you can comment on or make changes to this bug.