Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2622 - glibc-2.1.* breaks blackdowns java port of jdk117
Summary: glibc-2.1.* breaks blackdowns java port of jdk117
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 6.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-06 22:47 UTC by mmortens
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-10 13:57:42 UTC


Attachments (Terms of Use)

Description mmortens 1999-05-06 22:47:45 UTC
I upgraded to 6.0 today and going to glibc-2.1.1 broke my
jdk1.1.7.  jdk1.1.7 depends on a late version of glibc-2.0.7
as does the port of jdk1.2.  I depend on java daily.  I
noticed that your support registration say to come back on
5/10/1999 to register for 6.0 support, well I need help in
running glibc-2.0.7 along with glibc-2.1.1.

Comment 1 Bill Nottingham 1999-05-07 18:56:59 UTC
jdk messes with glibc thread internals. It shouldn't do that.
Make it use native threads and the problem should go away.

Comment 2 mmortens 1999-05-07 20:38:59 UTC
I switched jdk 1.1.7 over to using native threads and this appeared to
solve the problem.  Thanks


Note You need to log in before you can comment on or make changes to this bug.