Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2621 - "startx"/xinit broken!!!
Summary: "startx"/xinit broken!!!
Keywords:
Status: CLOSED DUPLICATE of bug 2402
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 6.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-06 22:38 UTC by Chris Evans
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-03 15:32:07 UTC


Attachments (Terms of Use)

Description Chris Evans 1999-05-06 22:38:51 UTC
Hi

If I drop to runlevel 3 (no X running by default) then
startx is observed to be broken. Actually technically it is
"xinit" or the X server that is broken.

The broken behaviour is 15 seconds of waiting at a blank X
screen before my window manager is launched.

Closer inspection reveals that "xinit" is waiting for a
signal from the X server, which NEVER ARRIVES, hence a 15
second timeout

Can you reproduce?? If not tell me ASAP and I will be more
specific

Comment 1 Chris Evans 1999-05-08 12:19:59 UTC
Have some additional comments :-)

It appears to be a race condition. If I boot to runlevel 3 and type
"startx", my X session launches fine.

If I exit the X session, and type "startx" again, all the binaries are
cached and load very quickly. Because of this speed increase, the
race condition is observed - startx hangs for 15 seconds showing a
blank X screen.

Comment 2 Jeff Johnson 1999-06-03 15:32:59 UTC
*** This bug has been marked as a duplicate of 2402 ***


Note You need to log in before you can comment on or make changes to this bug.