Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2619 - Missing a /usr/include/ndbm.h
Summary: Missing a /usr/include/ndbm.h
Keywords:
Status: CLOSED DUPLICATE of bug 2972
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-06 22:18 UTC by niles
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-01 22:43:22 UTC


Attachments (Terms of Use)

Description niles 1999-05-06 22:18:24 UTC
The Open Group's UNIX spec clearly states that there
should exist a file /usr/include/ndbm.h.  Now I understand
there's some controversey over which database to use
GNU or BSD, but a decision must be made. There must be
a <ndbm.h> file.  <db1/ndbm.h> does not make the standard.
(my pick would be the (GNU) gdbm version of ndbm.)

Comment 1 ct7 1999-05-12 21:28:59 UTC
reviously RedHat shipped this in glibc-devel-2.0.7-29.i386.rpm; why
isn't it being shipped now in glibc-devel-2.1.1-6.i386.rpm?  This is a
lousy way to treat people who are upgrading from previous versions --
I'm sure I could go back through all of my older RH5.X disks and find
that ndbm.h was in /usr/include ... why move it now?

The GPL license shouldn't be an issue since the GNU libraries are
being delivered as part of the base operating system.

Comment 2 David Lawrence 1999-06-01 22:43:59 UTC
*** This bug has been marked as a duplicate of 2972 ***


Note You need to log in before you can comment on or make changes to this bug.