Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2614 - GDM logins do NOT show up in utmp
Summary: GDM logins do NOT show up in utmp
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gdm
Version: 6.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
: 2655 3080 7130 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-06 21:31 UTC by Chris Evans
Modified: 2008-05-01 15:37 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-04 21:47:03 UTC


Attachments (Terms of Use)

Description Chris Evans 1999-05-06 21:31:54 UTC
I installed my system. I booted brand new system. I logged
in as root via the gdm login screen.

This login at the console via GDM, failed to put a login
record in /var/run/utmp.

(This has the side effect of making the "Utilities->User
Listing" tool look VERY ugly. When it sees no users logged
on it launches with an overly compacted layout. Try it!)

Comment 1 Preston Brown 1999-08-31 13:37:59 UTC
*** Bug 2655 has been marked as a duplicate of this bug. ***

Hi

Install RH6.0, choose to "launch X by default" during the
install.

When you boot the new system, GNOME pops up with a login
dialog. So far so good.

Now switch to a virtual console and type

startx -- -query 127.0.0.1 :1

This command starts X but FAILS to get to a login screen!
This is quite serious :-)

Note, if I change /etc/X11/prefdm so it points to "xdm", the
above command works fine.

Another note: when using gdm, traffic sent to the XDMCP port
queues up and is never read. The port should either be
fixed, or disabled- if it isn't used it's a security concern
:-)

------- Additional Comments From johnsonm@redhat.com  05/10/99 18:47 -------
The workaround for now is to enable debugging by changing
Enable=0 to Enable=1 in the [debug] section of /etc/X11/gdm/gdm.conf.
This is most certainly a workaround and not a bugfix...

The workaround does not fix the fact that it listens when not
configured to do xdmcp.

------- Additional Comments From   08/24/99 10:31 -------
A little extra info:  GDM will respond to XDMCP requests when they
are DIRECT or QUERY requests (sent to the specified host).   It fails
when the requests are of type BROADCAST.

Comment 2 Elliot Lee 1999-08-31 19:08:59 UTC
*** Bug 3080 has been marked as a duplicate of this bug. ***

xdm writes utmp/wtmp entries during login/logout in
GiveConsole and TakeConsole like so:

GiveConsole:/usr/X11R6/bin/sessreg  -a -w "/var/log/wtmp" -u
"/var/run/utmp" \
TakeConsole:/usr/X11R6/bin/sessreg -d -w "/var/log/wtmp" -u
"/var/run/utmp" \

But gdm doesn't, so when I log in via gdm, I can see "0
users".. this isn't a really big deal, but is it possible
that it could be fixed to track logins/logouts via gdm?

------- Additional Comments From malicki.1@osu.edu  05/26/99 22:59 -------
This can be fixed by the following, could you please include in next
release?

mkdir /etc/X11/gdm/{Pre,Post}Session
cp /etc/X11/xdm/GiveConsole /etc/X11/gdm/PreSession/Default
cp /etc/X11/xdm/TakeConsole /etc/X11/gdm/PostSession/Default


------- Additional Comments From jturner@redhat.com  05/27/99 10:34 -------
This issue has been forwarded to a developer for further review

------- Additional Comments From johnsonm@redhat.com  07/12/99 16:57 -------
Added mkp to CC so that he can evaluate this change for the next
version of gdm.

Comment 3 Elliot Lee 1999-08-31 23:10:59 UTC
assign to mkj for now, since he is currently the gdm point man.

Comment 4 mkp 1999-11-01 19:25:59 UTC
While the X supplied sessreg works fine for local displays, it does
not handle pseudo-ttys gracefully. I will probably end up writing a
small sessreg clone for gdm.

Comment 5 Elliot Lee 1999-11-29 17:39:59 UTC
*** Bug 7130 has been marked as a duplicate of this bug. ***

Comment 6 Havoc Pennington 2000-02-04 21:47:59 UTC
Patched to fix this.


Note You need to log in before you can comment on or make changes to this bug.