Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2609 - new LILO confuses SystemSoft BIOS
Summary: new LILO confuses SystemSoft BIOS
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: lilo
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-06 20:17 UTC by eric
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-01 22:31:03 UTC


Attachments (Terms of Use)

Description eric 1999-05-06 20:17:30 UTC
The version of LILO included with Red Hat 6.0 apparently
confuses the SystemSoft BIOS used on many low-cost AMD-based
laptop computers using the Intel TX Socket-7 chipset. It
apparently does not detect a valid boot signature on the
hard drive and refuses to load and run the boot sector.
Instead, the BIOS prompts for a floppy.

The computer boots up fine off of the boot floppy. Various
configurations of /etc/lilo.conf were tried:
   a)  Use "fdisk /mbr" from a Windows floppy, then set the
Linux partition as active. Use boot floppy into Linux, set
lilo.conf to write boot record to /dev/hda3 (the Linux root
partition). Run /sbin/lilo then reboot. Same result (BIOS
prompts for a floppy upon reboot).
  b) Use boot floppy into Linux, set lilo.conf to write boot
record to /dev/hda. Same result (BIOS prompts for a floppy
upon reboot).

Temporary work-around: boot off of the boot floppy,
downgrade to the Red Hat 5.2 version of LILO and run
/sbin/lilo . (With the same /etc/lilo.conf that did not work
with the Red Hat 6.0 version of LILO).

Note: This appears to be a BIOS-specific interaction. No
problems have yet been observed with LILO on desktop
machines using the AWARD or Phoenix BIOS.

Comment 1 David Lawrence 1999-06-01 22:31:59 UTC
We will need to obtain hardware that contains this brand of BIOS to
accurately troubleshoot the problem associated with LILO shipped with
6.0. This may take a while.


Note You need to log in before you can comment on or make changes to this bug.