Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2604 - Obsolete /sbin/raidadd command referenced in /etc/rc.d/rc.sysinit
Summary: Obsolete /sbin/raidadd command referenced in /etc/rc.d/rc.sysinit
Keywords:
Status: CLOSED DUPLICATE of bug 2328
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
: 2634 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-06 17:51 UTC by Paul Iadonisi
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-10 16:28:53 UTC


Attachments (Terms of Use)

Description Paul Iadonisi 1999-05-06 17:51:29 UTC
Looking at the man page for raidadd (from raidtools-0.90-3)
it is apparent that the /sbin/raidadd and /sbin/raidrun
commands are now obsolete.  The /sbin/raidstart command now
takes care of both functions.  In the /etc/rc.d/rc.sysinit
startup script, these two obsolete commands are referenced,
instead of /sbin/raidstart.  The script in it's current form
will not start raid devices on boot as it is intended.
Below is a (untested -- I haven't rebooted yet) patch
against rc.sysinit that should fix the problem.

---------- cut here --------
--- rc.sysinit.orig	Tue Apr 13 20:05:12 1999
+++ rc.sysinit	Thu May  6 00:47:42 1999
@@ -206,15 +206,10 @@
 fi

 # Add raid devices
-if [ -f /proc/mdstat -a -f /etc/raidtab -a -x /sbin/raidadd
]; then
-	action "Starting up RAID devices" raidadd -a
+if [ -f /proc/mdstat -a -f /etc/raidtab -a -x
/sbin/raidstart ]; then
+	action "Starting up RAID devices" raidstart -a

 	rc=$?

-	if [ $rc = 0 ]; then
-		raidrun -a
-		rc=$?
-	fi

 	# A non-zero return means there were problems.
 	if [ $rc -gt 0 ]; then

Comment 1 Paul Iadonisi 1999-05-06 17:54:59 UTC
Oops.  Lines 7/8 and lines 10/11 got wrapped.  Paste them together and
the patch should apply.

Comment 2 Bill Nottingham 1999-05-07 19:01:59 UTC
*** Bug 2634 has been marked as a duplicate of this bug. ***

The new raidtools (0.90) used in RH 6.0 do not contain
raidadd and raidrun any longer. However, there are still
calls to these programs in rc.sysinit:

if [ -f /proc/mdstat -a -f /etc/raidtab -a -x /sbin/raidadd
]; then
	action "Starting up RAID devices" raidadd -a
	rc=$?

	if [ $rc = 0 ]; then
		raidrun -a
		rc=$?
	fi
	(...)


In order to make the script work this should be changed to
the following:

if [ -f /proc/mdstat -a -f /etc/raidtab -a -x
/sbin/raidstart ]; then
	action "Starting up RAID devices" raidstart --all
	rc=$?
	(...)

Comment 3 Bill Nottingham 1999-05-10 16:28:59 UTC
*** This bug has been marked as a duplicate of 2328 ***

Comment 4 marcm 1999-05-24 02:43:59 UTC
Isn't this functonality what raid's auto detect features are for?  All
the raid code in /etc/rc.d/rc.sysinit should be commented out (or
deleted).

By "updating" /etc/rc.d/rc.sysinit as above you will probably cause
conflicts with existing autodetected raid systems (like mine).


Note You need to log in before you can comment on or make changes to this bug.