Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2597 - CROND stops running jobs if date changed to future and returned to normal.
Summary: CROND stops running jobs if date changed to future and returned to normal.
Keywords:
Status: CLOSED DUPLICATE of bug 2596
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: crontabs
Version: 5.1
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-06 13:04 UTC by innov8
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2001-04-10 21:59:31 UTC


Attachments (Terms of Use)

Description innov8 1999-05-06 13:04:28 UTC
Upon changing the date to dec 31 1999 using date --set, and
waiting for the rollover to jan 1 2000 the crond ran it's
jobs as normal.  Using date --set again and setting the
date back to normal the crond would not run any of it's
jobs.  The log file for the crond reported nothing.
Killing and restarting the daemon left and error in the
crond stating that the PID was already in use.  None of the
crontab files in either /etc/crontab or /var/spool/user
were modified when the date was jan 1.  The problem was
resolved by rebooting the machine.

Comment 1 Jeff Johnson 1999-05-06 16:24:59 UTC
*** This bug has been marked as a duplicate of 2596 ***


Note You need to log in before you can comment on or make changes to this bug.