Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2593 - httpd segfaults when reading from file using php3
Summary: httpd segfaults when reading from file using php3
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mod_php3
Version: 6.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL: http://alidrus.mlcc.com.my/~abu/rh6bu...
Whiteboard:
: 3369 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-06 08:07 UTC by abu
Modified: 2008-05-01 15:37 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-27 20:42:04 UTC


Attachments (Terms of Use)

Description abu 1999-05-06 08:07:48 UTC
There seems to be something very wrong with redhat 6.0's
version of mod_php3. perhaps the problem could be deeper
(like glibc for instance).The problem seems to manifest
itself when I try to access a file using fopen and
subsequently fgets on my php3 script. After a certain number
of fgets, the child process spawned by apache seems to die
off with a segmentation fault.

Here is how the bug can be reproduced:

When I run this script:

http://alidrus.mlcc.com.my/~abu/test.phps

I check the log file and get this message in the apache
logfile /var/logs/httpd/error_log:

[Thu May  6 14:53:59 1999] [notice] child pid 2078 exit
signal Segmentation fault (11)

The user who clicks on the link:

http://alidrus.mlcc.com.my/~abu/test.php3

would subsequently get a message saying "Document contains
no data".

Comment 1 whynot 1999-05-09 20:22:59 UTC
This also occurs on *fclose*. This is really serious and I don't see a
quick work-around :-(

This bug is also in the php3Bugdatabase at
http://bugs.php.net/bugs.php3?id=1313

Comment 2 whynot 1999-05-23 17:15:59 UTC
well, the announcement of PHP3.0.8 states that this bug is fixed. Now
if there is a rpm avaible any time soon this should be considered
fixed.

Comment 3 whynot 1999-05-28 21:38:59 UTC
I just tested the new 3.0.8-1 RPM of mod_php3. It DOES NOT fix the bug
when used with the apache that comes with Redhat 6.0. So you still
need to fix that bug. I am suprised that there are not more people
complaining about this bug since it is quite important if you plan to
use RedHat 6.0 as a Webhosting-Platform

Comment 4 Preston Brown 1999-06-14 21:18:59 UTC
*** Bug 3369 has been marked as a duplicate of this bug. ***

The mod_php3 RPM from the errata is not really compiled with
postgresql support, as the errata info would lead one to
believe.  To enable postgresql support, the line in the SPEC
file "--with-postgresql" must be changed to
"--with-pgsql=/usr/lib/pgsql"


------- Additional Comments From bentonw@stolaf.edu  06/09/99 13:03 -------
rather, that should be "--with-pgsql", with no directory specified --
sorry, I spoke too soon

------- Additional Comments From jbj@redhat.com  06/10/99 11:09 -------


*** Bug 3384 has been marked as a duplicate of this bug. ***

The .spec file uses --with-postgresql.  It SHOULD read,
"--with-pgsql".

Comment 5 Preston Brown 1999-08-27 20:42:59 UTC
all of these php bugs have been fixed for the upcoming release.


Note You need to log in before you can comment on or make changes to this bug.