Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2569 - Cannot find Novell servers
Summary: Cannot find Novell servers
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ncpfs
Version: 6.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
: 2692 2787 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-05 11:51 UTC by tcc1000
Modified: 2008-05-01 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-11 16:35:21 UTC


Attachments (Terms of Use)

Description tcc1000 1999-05-05 11:51:55 UTC
slist does not list any servers, error message:

slist: No server found in ncp_open

ncpmount does not work either - it can't find any servers
either.

tcpdump shows that there is a broadcast and some form of
communication, but this doesn't last as long as correct
conversation.

Contrib version 2.2.0-2 works fine, so it's definitely in
ncpfs package.

Comment 1 Bill Nottingham 1999-05-10 20:02:59 UTC
are you running this as root or another user?

Comment 2 tcc1000 1999-05-11 09:58:59 UTC
CORRECTION: ncpmount, etc. appear to work correctly.

slist fails to work either as root or another user

UNLESS logged in to a Novell server, in which case it works correctly
both as root and another user. I hope this helps.

Comment 3 Bill Nottingham 1999-05-11 14:56:59 UTC
*** Bug 2692 has been marked as a duplicate of this bug. ***

slist does not work, it just returns:

slist: No server found in ncp_open

ncpmount and other IPX utilities work well,
no problems copying files from linux to multiple
Netware servers.


------- Additional Comments From tcc1000@cam.ac.uk  05/11/99 06:00 -------
Same as bug 2569.

Comment 4 Bill Nottingham 1999-05-11 16:35:59 UTC
Will be fixed in ncpfs 2.2.0.14-1, which will be in the next
Raw Hide release. Meanwhile, here's a patch.

--- ncpfs-2.2.0.14/lib/ncplib.c.orig	Tue May 11 12:02:49 1999
+++ ncpfs-2.2.0.14/lib/ncplib.c	Tue May 11 12:09:21 1999
@@ -1111,7 +1111,10 @@
 		sprintf(b1, "%d", type);
 		buf2[1] = "-t";
 		buf2[2] = b1;
-		buf2[3] = server;
+	        if (strlen(server)==0)
+	          buf2[3] = NULL;
+	        else
+		  buf2[3] = server;
 		buf2[4] = NULL;

 		err = exec_nwsfind(buf, sizeof(buf), buf2);

Comment 5 Bill Nottingham 1999-05-13 15:53:59 UTC
*** Bug 2787 has been marked as a duplicate of this bug. ***

When last used under 5.2, slist correctly returned a list
of available netware servers.

Under 6.0 this requires that some server be mounted.

Sounds like a catch-22 doesn't it.

Comment 6 Michael Redinger 1999-06-08 17:02:59 UTC
Hm, I just upgraded to 2.2.0.15 (rpm package from rawhide). Doesn't
work either ...


Note You need to log in before you can comment on or make changes to this bug.