Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2563 - ping localhost shows corrupted packets (ping bug)
Summary: ping localhost shows corrupted packets (ping bug)
Keywords:
Status: CLOSED DUPLICATE of bug 1786
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: netkit-base
Version: 6.0
Hardware: alpha
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-05 09:35 UTC by David Woodhouse
Modified: 2015-01-07 23:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-05 11:51:24 UTC


Attachments (Terms of Use)

Description David Woodhouse 1999-05-05 09:35:54 UTC
Networking is fine - only ping is complaining....

64 bytes from 127.0.0.1: icmp_seq=0 ttl=255 time=0.1 ms
wrong data byte #8 should be 0x8 but was 0xe9
        c d e f 10 11 12 13 14 15 16 17 18 19 1a 1b 1c 1d 1e 1f 20 21 22 23 24 25 26 27 28 29 2a 2b
        2c 2d 2e 2f 0 0 0 0 0 0 0 0 0 0 0 0
64 bytes from 127.0.0.1: icmp_seq=1 ttl=255 time=0.0 ms
wrong data byte #8 should be 0x8 but was 0x5
        c d e f 10 11 12 13 14 15 16 17 18 19 1a 1b 1c 1d 1e 1f 20 21 22 23 24 25 26 27 28 29 2a 2b
        2c 2d 2e 2f 0 0 0 0 0 0 0 0 0 0 0 0

... and doing unaligned memory accesses...
ping(8664): unaligned trap at 0000000120002b04: 0000000120117784 29 1
ping(8664): unaligned trap at 0000000120002b2c: 000000012011777c 29 2

Comment 1 Jeff Johnson 1999-05-05 11:51:59 UTC
*** This bug has been marked as a duplicate of 1786 ***

Comment 2 EricsON 1999-09-08 21:30:59 UTC
It might help if bug 1786 was available for reference purposes *g*


Note You need to log in before you can comment on or make changes to this bug.