Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2556 - glibc segfaults when using gdb on qt apps (vfprintf problem?)
Summary: glibc segfaults when using gdb on qt apps (vfprintf problem?)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gdb
Version: 6.0
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
: 1772 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-05 04:45 UTC by dcthomp
Modified: 2008-05-01 15:37 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-23 01:04:51 UTC


Attachments (Terms of Use)

Description dcthomp 1999-05-05 04:45:42 UTC
When running gdb on a Qt application, the program will
segfault in vfprintf when printing an initial debug message.
Here's the last two entries in the stack

#0  0x404dd5a8 in main_arena () from /lib/libc.so.6
#1  0x4043df06 in buffered_vfprintf (s=0x404dd500,
format=0x40171ca0 "Qt: gdb: -nograb added to command-line
options.\n\t Use the -dograb option to enforce grabbing.",
args=0xbffff2ac) at vfprintf.c:1752

I set the priority to low because you can get around this by
starting the program with "run -nograb". It seems like it
might be indicative of larger problems, though.

Comment 1 dcthomp 1999-05-06 17:30:59 UTC
The program below will demonstrate the problem. It will run
normally (do nothing) from a command line, but dies when run
from gdb.

#include <qapp.h>
int main( int argc, char** argv )
{
  QApplication a(argc,argv);
  return a.exec();
}

Comment 2 Preston Brown 1999-07-12 16:00:59 UTC
Verified.  GDB 4.18 can debug this program without problems.  I really
suggest we get an update for gdb out the door for 6.0 asap.  It isn't
just Qt -- anyone debugging moderately complex C++ applications cannot
debug with Red Hat Linux 6.0.

Comment 3 Preston Brown 1999-07-12 16:49:59 UTC
*** Bug 1772 has been marked as a duplicate of this bug. ***

1. Get the binary at the given URL.
2. gunzip it and run 'gdb linux-midi' (does not need to be run).
3. Type 'print CORBA_tk_null'.
Voila, core dump.


As an aside, why doesn't the package in 5.9 have the x86 hardware breakpoint support? The 5.2 package did.

------- Additional Comments From kingdon@redhat.com  07/12/99 11:12 -------
There is no DNS entry for
http://www.circ.us.eu.org/~sopwith/linux-midi.gz
Does this test case have a new location?

Comment 4 Jim Kingdon 1999-08-23 01:04:59 UTC
Please try gdb-4.18-3 which is now in Rawhide.


Note You need to log in before you can comment on or make changes to this bug.